Main Menu

Tag Archives | heartbleed

Heartbleed security vulnerability

Public Service Announcement

“Heartbleed” is a security vulnerability in ubiquitous open source software used to implement secure communications with web servers. Because of this vulnerability, information you enter into a secure web page on an affected server might be accessible remotely. One security consultant said that on a seriousness scale from 1 to 10, “heartbleed is an 11.”

Obama Conspiracy Theories as best I can tell is not affected by heartbleed because logons to this site don’t use secure sockets in the first place. :shock:

This is one of those times when even I am changing my passwords.